Microsoft has completed mitigation of the Azure Event Grid outage in the East US region as of 3:09 AM Eastern. Our team is actively monitoring the platform to confirm full resolution and ensure all affected functionality has been restored.
Posted Jun 10, 2026 - 09:11 EDT
Update
We are aware of an active issue affecting Unlimited Financials users. Microsoft has declared an outage in the Azure Event Grid service (East US region), impacting data persistence across the platform.
Known areas of impact include Notes, Attachments, and Interventions. As this incident progresses, other areas of the system may be affected.
We are monitoring Microsoft's remediation efforts and will post updates as they become available.
Posted Jun 09, 2026 - 15:04 EDT
Identified
The issue has been identified and our team is working towards a resolution.
Posted Jun 09, 2026 - 13:14 EDT
Investigating
We are currently aware of an issue with saving notes and attachments. Our team is investigating the source and scope of the problem in pursuit of resolution.