Microsoft Azure Service Outage

Incident Report for Unlimited Financials SPACE

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 12:46 EDT

Identified

We are aware of an issue impacting Microsoft Azure. As a result, Unlimited Financials users are experiencing slowness across the system. Our team is engaged with Microsoft to provide input and monitor progress to resolution.
Posted Apr 09, 2026 - 14:31 EDT
This incident affected: SPACE Environment.